Jump to content
democar1

Dash is faded AKATV

Recommended Posts

I have a Honda Foreman 450ex and I have a dash display that is very faded and hard to see anything. I found someone on here with a name of AKTV that looks like he knows how to fix them. Can someone point me in the right direction to reach them? I just joined so it wont let me send a direct message to him. I am in Iowa City Iowa. Thanks 

Edited by democar1
Add pictures

Share this post


Link to post
Share on other sites
 

Hi democar1 and welcome to the forum!

I can most likely get you fixed up, I just need to know what you have going on exactly

Post a few pictures of you speedometer with the headlights turned on so its illuminated and I can

better see what you have going on

I have sent my contact information to you as well so check your message box

See you around!

AKATV

Share this post


Link to post
Share on other sites
 
1 hour ago, AKATV said:

Hi democar1 and welcome to the forum!

I can most likely get you fixed up, I just need to know what you have going on exactly

Post a few pictures of you speedometer with the headlights turned on so its illuminated and I can

better see what you have going on

I have sent my contact information to you as well so check your message box

See you around!

AKATV

Hey man I also have a 04 Honda rancher es 4x4. The screen is faded and wanted to see if you could help

Share this post


Link to post
Share on other sites
 

Hi Chase welcome to the forum

post a few pictures ofwhat you have going on and we can take it from there

I sent you my contact information as well

 AKATV

Share this post


Link to post
Share on other sites
 
 

 

37 minutes ago, democar1 said:

Need new rubber switch covers also

20211115_085600.jpg

I need you to turn the headlights on so the display will illuminate so I can see issues

It appears that you need to have your polarizing films replaced

if you need your rubber buttons to be replaced, you are  going to have to purchase a new top cover from Honda

The buttons are actually built into the top cover and are not replaceable  

Share this post


Link to post
Share on other sites
 

Hello AKATV. Can you send me your contact info please. I don’t have pics of my meter at the moment, but can get some. I am having same issues with it not illuminating the numbers. Seems I need the polarizing films replaced (based on previous post),

Share this post


Link to post
Share on other sites
 

 

Welcome to the forum!

I mcan repair it for you no problem, 

send a few pictures when you can.

I have sent my contact information to your message box as well

AKATV

Share this post


Link to post
Share on other sites
 

Hello AKATV! I'm new to the forum and I have problems with my display. Can you help me with my 2000 Foreman 450ES? Any help would be appreciated! 

IMG_1798.jpg

IMG_1799.jpg

Share this post


Link to post
Share on other sites
 

Hi and welcome to the forum!

 Thanks for the pictures, its a big help

 I might be able to help you out, 

The first thing you need to do is open up the speedometer case and take a good look at that circuit card

Looking at your picture, I can’t tell if you  need polarization films replaced on LCD or if your display is blank because that crack in your top cover let water in and ruined your circuit card

post a few pictures of what you find and we can take it from there.

I am interested to see if you can see any trace of numbers on the hours or mileage once you get the top cover up if you hold it in an angle either way sometimes you can see a trace of the display numbers

I will send you my contact information to your message box as well

talk to you soon and Happy Holidays!

AKATV

Share this post


Link to post
Share on other sites
 

AKATV,

Thank you for the quick response.

Happy holidays to you too!

I believe that your initial response was correct. I don't believe that this circuit board went down with the titanic but it has definitely visited it a few times.

I do not see any visible numbers on the display. There was water in the display case when I separated the lens from it. 

What are your recommendations? 

IMG_1801.jpg

IMG_1802.jpg

IMG_1803.jpg

IMG_1804.jpg

IMG_1805.jpg

Share this post


Link to post
Share on other sites
 

Actually your circuit card doesn’t look too bad if you’d like to send it to me I can at least put a test screen on it to make sure that it’s functioning properly before attempting any other repairs

Just keep in mind, if you get this card repaired you’re going to need to get a better top cover put on it  or you’re just going to eventually end up ruining the circuit card due to water infiltration

I have a buddy with a similar meter and he just put a piece of clear tape over the crack and it’s been working for years but that’s how he does things LOL

I will also send you my contact information to your message box if you’d like to contact me about a repair

AKATV

Share this post


Link to post
Share on other sites
 

AKATV not sure how to message you I need a display repaired as well if you could send me your information 

Share this post


Link to post
Share on other sites
 

Hi AKATV, 

 

I just joined the forum based on some posts about the Display Meter for a 2004 Honda Rancher TRX350FE.  The meter only displays around the edges and won't display the speed, etc. any more.  I tried to order a new one but was told that part is discontinued by Honda.  Can this be repaired?  How do I contact you regarding this if it can?

 

Thanks,

 

STAWO

72FAA366-6270-472E-B625-3149299A33ED_1_102_o.jpeg

7D2FB608-A401-478C-9373-A41A81250D58_1_105_c.jpeg

694F4D70-47F6-4132-9E95-2B40E1582848_1_105_c.jpeg

F814F238-123E-47BE-8D69-2BD9CE76F1BD_1_105_c.jpeg

6B6341CE-A46A-4E6D-B852-79FAA193F2B5_1_105_c.jpeg

03687440-A34F-480B-B865-B738EEB0985D_1_105_c.jpeg

Share this post


Link to post
Share on other sites
 

Hi Stan

Welcome to the forum!

I can repair it for you no problem

Looks like you have UV damage and possibly some moisture intrusion (dark patches)

I sent my contact information to your message box

Share this post


Link to post
Share on other sites
 

Attn AKAtv, I was told you're the man I need to talk to I have an 06 Honda rancher 350 ES fe and my dash is broken I'm not sure if anything on the screen lights up at all because the wiring harness is also burned up unfortunately this part is discontinued and I can't find one anywhere online to buy think you can help?

16609619092443956471448561068147.jpg

Share this post


Link to post
Share on other sites
 

Pretty hard to tell if it’s not powering up but based on the fact that your plastic top cover is broken out, I can pretty much tell you that the internal circuit card is probably ruined and corroded by water so it’s safe to say at this point you’re pretty much going to need to have a whole new display assembly

If you want remove the plastic top cover so we can better see the circuit card I can let you know if it might be repairable or not

Share this post


Link to post
Share on other sites
 
 

Welcome to the form !

Before we go shipping things off, let’s get a good handle on what you have going on and your year make a model

Post a picture or two and a description of the problem and I will send my contact information to your message box

Share this post


Link to post
Share on other sites
 

I need help also AKATV! Bought this one for the kids to not fight over 1. Will get photos over weekend. Police confiscate in city, farm country stored.Sun damaged  I see light display just can't make anything out. Thx in advance 

Share this post


Link to post
Share on other sites
 

Welcome to the Forum!

I can most likely repair your display for you just send me some pictures and we can get it sorted out I’ll also send my contact information to your message box as well

 

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...