Jump to content
Colbybogolin

Strange sound coming from left rear hub. Maybe.

Recommended Posts

 

have no clue where it’s coming from. My assumption is the hub. Fresh axle bearing and rear end. Honda rancher 420. 
 

Share this post


Link to post
Share on other sites
 

So is that the front or the rear we listening to 

 

Share this post


Link to post
Share on other sites
 
 

So is it IRS or a straight axle 

 

  • Like 1

Share this post


Link to post
Share on other sites
 
 

 

Well there goes my theory , I was thinking cv-shaft ---- I think there is a  spacer collar over the axle , remember seeing it  ----sounds like something is jammed up tight 

 

Share this post


Link to post
Share on other sites
 

I took the wheel off and the castle nut was super loose. I gave it a good snug and the sound went away! 👍👍

Share this post


Link to post
Share on other sites
 

thanks for the update ....  just out of curiosity .... can you post pics....  usually a loose hub will show signs like, fine rust , or metalic powder ...

Share this post


Link to post
Share on other sites
 

  How did it come loose . No cotter key on that hub castle  nut ?

  • Like 1

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...