Jump to content
Jmh-500

Honda 500 (rattling noise and 4x4 light flashing)

Recommended Posts

Hi all, I've got a 2010 Honda foreman 500, it's had a top end rebuild around 30hours ago, when I let off the throttle there's a rattling sound coming from inside, I've uploaded it on the video, also my 4x4 light flashes 5 times and then sometimes it flashes just twice 🤯🤯🤯 I can't upload the video for some reason, thankyou in advance 

Share this post


Link to post
Share on other sites
 

Hello and Welcome!

 

Upload your video to Youtube then post the link here in the forum.

The link will automatically embed and the video will show up in the thread.

There is no way to upload your video directly to the site at this time.

 

I think the flashing 4x4 light on these model says the battery is low.

 

Check your service manual and post the exact model so we know what you are working with.

Share this post


Link to post
Share on other sites
 

is the video on  YouTube ? if so just post the link here. does is act up just stationery, or when your riding ? 

 

Share this post


Link to post
Share on other sites
 

5 times is front drive issue.  Mine did it on the last ride, and when I shut it off and back on it went away.  More than likely moisture in a connector.

 

Rattle when you let off the throttle is something we'll need to hear.

Share this post


Link to post
Share on other sites
 

my money say's its the speed sensors. and they did not make a 2010 model, 2009, 2011 models in usa. we need the vin numbers please.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...