Jump to content
SeekanDestroy

2001 Honda Foreman 450ES not showing MPH

Recommended Posts

Posted (edited)

One day when i was out riding i noticed my speedo was only reading 0, Noticed nothing else until i was being hard on it and i couldn't shift anymore had 3 dashes where it shows you what gear you in and the only way to fix it is to shut it down and restart and rock it back and fourth to get it back into neutral. Is there anything it could be besides the speed sensor?

Edited by SeekanDestroy

Share this post


Link to post
Share on other sites
 

deff a speed sensor for sure !., before buying parts, check the connection at the sensor.

Share this post


Link to post
Share on other sites
 

Already removed connection and it look good no dirt or moisture. So looks like I'm buying a new speed sensor. They are not cheap... xD thanks for the quick response.

Share this post


Link to post
Share on other sites
 
13 hours ago, shadetree said:

deff a speed sensor for sure !., before buying parts, check the connection at the sensor.

Do you happen to know the part number I looked on partszillza and it looks nothing like the speed sensor I have?

Share this post


Link to post
Share on other sites
 
 
 
 
 
14 hours ago, SeekanDestroy said:

Already removed connection and it look good no dirt or moisture. So looks like I'm buying a new speed sensor. They are not cheap... xD thanks for the quick response.

before you buy anything !!, pull that sensor out, and ohm it if it can be done by the service manual ?, also, have a look to see if the gears inside there really turn when in gear ?.

Share this post


Link to post
Share on other sites
 
1 hour ago, SeekanDestroy said:

Do you happen to know the part number I looked on partszillza and it looks nothing like the speed sensor I have?

found this for ya if ya HAVE to buy a new speed sensor ? --> Honda 37700-HM7-751 - SENSOR ASSY., SPEEDOMETER | Partzilla.com . please check rocky mountain atv for the same part, will be cheaper !.

  • Like 1

Share this post


Link to post
Share on other sites
 
Posted (edited)

Alrighty sounds good I will tear it back out this afternoon and test it and look at the gears.

Edited by SeekanDestroy

Share this post


Link to post
Share on other sites
 
Just now, SeekanDestroy said:

Alrighty sounds good I will tear it back our this afternoon and test it and look at the gears.

i see how its made in the pic i linked ^^, check the shaft, and check to make sure the inside matting area does in fact turn when in gear ??. should be a female end..inside the rear cover there where it mounts.

Share this post


Link to post
Share on other sites
 
Just now, shadetree said:

i see how its made in the pic i linked ^^, check the shaft, and check to make sure the inside matting area does in fact turn when in gear ??. should be a female end..inside the rear cover there where it mounts.

Going to be fun trying to see in that hole..xD

Share this post


Link to post
Share on other sites
 
7 minutes ago, SeekanDestroy said:

Going to be fun trying to see in that hole..xD

flashlight and a mechanics mirror works very well !.

Share this post


Link to post
Share on other sites
 
4 minutes ago, shadetree said:

flashlight and a mechanics mirror works very well !.

Guess it's time to buy a mechanics mirror or just use my wife's makeup mirror...haha  thanks for the help.

  • Like 1

Share this post


Link to post
Share on other sites
 
2 minutes ago, SeekanDestroy said:

Guess it's time to buy a mechanics mirror or just use my wife's makeup mirror...haha  thanks for the help.

lol wifes makeup mirror..now thats using yer head !. prob the best use that mirror will ever have huh ?..rofl.

  • Haha 1

Share this post


Link to post
Share on other sites
 
12 minutes ago, shadetree said:

lol wifes makeup mirror..now thats using yer head !. prob the best use that mirror will ever have huh ?..rofl.

Yah everytime she uses it I don't notice a difference so atleast what I paid for it I can finally use it to fix something..lol

  • Haha 2

Share this post


Link to post
Share on other sites
 
53 minutes ago, SeekanDestroy said:

Yah everytime she uses it I don't notice a difference so atleast what I paid for it I can finally use it to fix something..lol

rofl..good one !.

Share this post


Link to post
Share on other sites
 
On 5/21/2021 at 11:54 AM, shadetree said:

i see how its made in the pic i linked ^^, check the shaft, and check to make sure the inside matting area does in fact turn when in gear ??. should be a female end..inside the rear cover there where it mounts.

Looked in the hole can't see nothing so I think it's time to dump 120 on a new speed sensor 😞

20210522_151942.jpg

20210522_151818.jpg

  • Like 1

Share this post


Link to post
Share on other sites
 

Did you use the wife's make up mirror ? .... 

Share this post


Link to post
Share on other sites
 
 
4 hours ago, SeekanDestroy said:

Looked in the hole can't see nothing so I think it's time to dump 120 on a new speed sensor 😞

20210522_151942.jpg

20210522_151818.jpg

ok..BEFORE you buy that speed sensor !!!!!!!, take a cordless drill, put the shaft of this sensor in it, turn the key on, work the drill..watch the display..does it show any speed ??.

  • Like 2

Share this post


Link to post
Share on other sites
 
21 minutes ago, shadetree said:

ok..BEFORE you buy that speed sensor !!!!!!!, take a cordless drill, put the shaft of this sensor in it, turn the key on, work the drill..watch the display..does it show any speed ??.

Didn't even think of trying that will have to do it tomorrow to late tonight. Thanks for the advice.

  • Like 1

Share this post


Link to post
Share on other sites
 
10 minutes ago, SeekanDestroy said:

Didn't even think of trying that will have to do it tomorrow to late tonight. Thanks for the advice.

yw :-).

Share this post


Link to post
Share on other sites
 
15 hours ago, shadetree said:

ok..BEFORE you buy that speed sensor !!!!!!!, take a cordless drill, put the shaft of this sensor in it, turn the key on, work the drill..watch the display..does it show any speed ??.

tested with a drill, and nothing still reads 0 i was thinking maybe a broken wire but it happened when i was just going down my driveway, so it's time to just order a speed senor.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...