Jump to content

Recommended Posts

I have a 300trx Honda 2000 and when I’m riding it it makes a popping and scraping sound. And in the back in this picture it gets really hot and smells like it’s burning and it scrapes metal of the disk thing in the back . Anybody know what’s wrong with it??

Quote

 

 

Share this post


Link to post
Share on other sites
 
 
 

i see you made it here, sit tight, the sport guys will be around, it is the weekend, and holiday weekend at that. your model is a trx300ex, as i said on other site, i am not much for sport atvs ?, but from what i gather so far, it seems your rear disk brakes are in need of some repair :-).

  • Thanks 1

Share this post


Link to post
Share on other sites
 

Welcome Zoey , I ride utility atvs also , I have had a sport , my guesses would be brake pads worn out , caliper sticking making brakes drag g, bad carrier bearing letting the axle float around and scrape the disc ---- I would jack the back off the ground and spin them in the air , you might be able to isolate the noise 

 

Share this post


Link to post
Share on other sites
 

From the looks of that picture that brake caliper is installed wrong. The slide plate is on the wrong side of the brake stay. This would make it impossible to install a brake pad in there so i would have to imagine its either worn down to thin metal or not in there at all.

 

Share this post


Link to post
Share on other sites
 
 

I think I see what you are looking at , the rotor is not in the middle of the caliper  ---------    it also looks like the parking brakes is deleted with a block , 

Share this post


Link to post
Share on other sites
 
1 minute ago, Fishfiles said:

I think I see what you are looking at , the rotor is not in the middle of the caliper  ---------    it also looks like the parking brakes is deleted with a block , 

Yeah deleted with a block off plate. Common practice on sport quads. They never work anyway lol

  • Like 1

Share this post


Link to post
Share on other sites
 
50 minutes ago, SlammedRanger said:

Yeah deleted with a block off plate. Common practice on sport quads. They never work anyway lol

Hah, I was wondering what that was. Such a nice piece of billet aluminum looked out of place on my 200X.

 

  • Like 1

Share this post


Link to post
Share on other sites
 

You can see a block off plate good in this pic , it is powder coated black and covering the cable brake lever hole , after cable was replaced with hydraulics 

IMG_8945.JPG

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...