Jump to content
AKATV

Foreman 450 Speedometer Repair Before & After Pics

Recommended Posts

 

Welcome to the forum!

Yes, I am currently still repairing these.
I will send my contact information to your message box.

-AKATV 

Share this post


Link to post
Share on other sites
 
 

Hi 

Welcome to the forum!

I will send my contact information to your message box

Hope to see you around the forum

-AKATV

Share this post


Link to post
Share on other sites
 

Hey AKATV, I have a 2003 TRX450FM that the meter doesn’t seem to be working on. Can you fix this? Thank you. 

Share this post


Link to post
Share on other sites
 

Hi and welcome to the forum!

Post a picture or two with 

headlights on so its illuminated 

(if powering up)

I will send contact information to your 

message box for you as well 

-AKATV 

Share this post


Link to post
Share on other sites
 

Here's a pic...I believe this may be irreparable, but I thought I'd give it a shot.  It's from a Foreman 99 450s that is a complete basket case.  Kids, never buy from Marketplace at night, no matter how good the deal sounds! 🙂 

 

There was no back on the PCB housing at all...it was held into the front of the pod by 14g wires strategically tied to the 4 phillips screws, just dangling in space by tension!

 

I also picked up some OEM connectors and pins, because I was pretty sure I was going to need to Mad Max something, and I was hoping to just trace pin-outs to something else that had the same signaling that wasn't made for a Foreman.  Ideally, I'd be able to get MPH and gear position....that's all I really want.  The backllght on this does work, as does the round LEDs, so that gives me hope that I could meter the pins and try to figure out what's going on to wire in a Chinese generic display or even an arduino.

 

Anyway, AKATV, is this one beyond repair?  Has anyone figured out the wiring to hack in a non-Honda display?

 

 

speedo.jpg

Share this post


Link to post
Share on other sites
 

The black ink type mark on the LCD is non-repairable it’s permanent and is actually internal damage

Your circuit card doesn’t show any obvious signs of water damage or anything else
Make sure you have power on the black/red wire in the brown/black wire using green as ground with key on and see if it powers up then

if so, then you only need to work on getting a replacement display

Let me know how you make out and I’ll send my contact information to your message box if you’d like to look into a repair

-AKATV 

 

 

Edited by AKATV

Share this post


Link to post
Share on other sites
 

Thanks AK.  Any leads on replacement displays?  I'm assuming these are proprietary and there's no NOS ones out there.  Aside from the display, everything works as expected on mine, so yeh, the board is solid.

Share this post


Link to post
Share on other sites
 

OK so what you’re saying is your board powers up and works just fine and displays properly except for the black spot- is that correct?

Honda never sold the display separately from the speedometer assembly. It was all one unit and they were discontinued many years ago.

The foreman 450 S model displays were prone to this internal failure, causing the black spots more than any other model so even when you can find one in working condition usually the display is bad so they are a little trickier to come across them in good working condition
I might be able to source a used working LCD display for you if you’d like to contact me for a repair I sent my contact information to your message box

-AKATV

Edited by AKATV

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...