Jump to content
Pete L.

2005 Rubicon Trail Edition - Flashing D1, D2, ESP.

Recommended Posts

Hi there. 
Just became a member and would appreciate advice on trouble shooting. 
 D1, D2, ESP Flashing and only have first gear. 
Reverse has like a rev limiter. 
 

If I turn the key on, start it and right away put it  in D and get on the throttle right away, I have all the gears.  As soon as i come to a stop, it goes back into flashing the D1, D2, and ESP.  


Does someone have manuals for troubleshooting this?

Share this post


Link to post
Share on other sites
 

welcome to our forums, there should be ?, a service manual you can down load for free in our service manual section :-).

  • Like 1

Share this post


Link to post
Share on other sites
 
 
 
 

Howdy Pete.  I hope you get your Rubicon going.

Share this post


Link to post
Share on other sites
 
 
 

 What a great site.  Happy to find it. 
With finding a manual on this site I was able to determine it was the Cam shift angle sensor. Installed a new one in and we’re ready to ride again. 
Thanks 👍

  • Like 2

Share this post


Link to post
Share on other sites
 
9 minutes ago, Pete L. said:

 What a great site.  Happy to find it. 
With finding a manual on this site I was able to determine it was the Cam shift angle sensor. Installed a new one in and we’re ready to ride again. 
Thanks 👍

thank you for the update !, now, just cuz ya got it fixed ?..don't mean ya gotta stay away !..lol.

  • Like 1

Share this post


Link to post
Share on other sites
 
 
 

Welcome aboard.  Glad you got it fixed quickly. Hope you used OEM parts!

  • Like 2

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...