Jump to content

Recommended Posts

TRX300FW - 1995 Red --- this one has some mods done to it , it has a Wisco 10.5/1 piston , 250 cam , sprocket and chain , bored 250 jug and chain adjuster , ported head , 54% reduction , EBC clutch pac , 424 kick out , disc conversion front , 250 master cylinder  skid plate , stick stoppers , custom front bumper guard and fairlead , floor boards ,  winch , snorkeled , 250 rear end , 250 spring loaded drive shaft/u-joint , led lights , Mudzilla 26s on ITP 4 slot rims , engine is powder coated red , black and silver ( bad deal there ) and a few other things 

 

this one is running hot , I have a cooler to put into it , but I know that is not the problem of it running hot , think it has something to do with a  freebie power coating job on the engine and the internal pieces come loose and I have found flakes in the filter now a few times 

IMG_4072.JPG

fullsizeoutput_15e.jpeg

IMG_5905.JPG

  • Like 5

Share this post


Link to post
Share on other sites
 

Looks amazing. Followed your complete thread on this build on the old forum. Will you be tearing the motor apart to check why its running hot?

  • Like 1

Share this post


Link to post
Share on other sites
 

I'm glad you brought these threads back to life! I really enjoyed each one! 

Edited by _Wilson_™

Share this post


Link to post
Share on other sites
 
1 hour ago, machinecrook said:

Looks amazing. Followed your complete thread on this build on the old forum. Will you be tearing the motor apart to check why its running hot?

Yes , I think the first step is remove the side cover to check the screen , would bet it is going to be full of flakes 

  • Like 1

Share this post


Link to post
Share on other sites
 
On 1/10/2020 at 2:59 PM, Fishfiles said:

TRX300FW - 1995 Red --- this one has some mods done to it , it has a Wisco 10.5/1 piston , 250 cam , sprocket and chain , bored 250 jug and chain adjuster , ported head , 54% reduction , EBC clutch pac , 424 kick out , disc conversion front , 250 master cylinder  skid plate , stick stoppers , custom front bumper guard and fairlead , floor boards ,  winch , snorkeled , 250 rear end , 250 spring loaded drive shaft/u-joint , led lights , Mudzilla 26s on ITP 4 slot rims , engine is powder coated red , black and silver ( bad deal there ) and a few other things 

 

this one is running hot , I have a cooler to put into it , but I know that is not the problem of it running hot , think it has something to do with a  freebie power coating job on the engine and the internal pieces come loose and I have found flakes in the filter now a few times 

IMG_4072.JPG

fullsizeoutput_15e.jpeg

IMG_5905.JPG

Fish, in relation to the light bar and LED head lights, what sort of brightness do you get from all that? Any pics of it in the dark?

 

The stock bulbs I have on mine are fine for my current use but I'm interested to see what output something like your outfit can give?

  • Like 1

Share this post


Link to post
Share on other sites
 

Turbo , I don't know how I messed your post ^ , bit I did ---- the led lights are insane , they  really lights it up deep into the trees ,  don't think I have any good  night time light pics at the monment ---- people riding in front need sun block , lol 

  • Haha 4

Share this post


Link to post
Share on other sites
 
 
 

paint on the motor should not make them run hot bro !. i paint mine all the time, and not one of them has ever ran hot. oil not flowing good will cause this, bad oil pump, or weak oil pump, not enough air flow to the engine will make them run hot.

Share this post


Link to post
Share on other sites
 

The powder coating I was mentioning about making it run hot ---- I wish I wouldn't have seen them jackpots , thinking about taking a ride now  IMG_5959.JPGIMG_5957.JPG

  • Like 3

Share this post


Link to post
Share on other sites
 
1 hour ago, Fishfiles said:

The powder coating I was mentioning about making it run hot ---- I wish I wouldn't have seen them jackpots , thinking about taking a ride now  IMG_5959.JPGIMG_5957.JPG

wow..he paint the inside of it ??..lol.

  • Like 1

Share this post


Link to post
Share on other sites
 

I can only imagine what the oil pickup screen looks like?

  • Like 2

Share this post


Link to post
Share on other sites
 
 
 

At this point I think the case needs to be split and the engine needs to be completely gone thru 

  • Like 3

Share this post


Link to post
Share on other sites
 
2 hours ago, TRX Student said:

Whats the fix? Just make oil changes abit more frequently, hoping nothing plugs up?

as fish ^^^ said..motor has to come out, split, gone through, then back together.

  • Like 1

Share this post


Link to post
Share on other sites
 

 ^Shade^ made me an offer to go thru  this red flake infested  300 engine , I am going to take him up on that offer  , I know it will be done first class ---- got to get it out the frame  and on a GreyHound bus up to Arkansas ,a multi-state rebuild 

 

Found a pic when the powder coating job  was first done -------  beauty is only skin deep on this one ---- cause it is ugly inside ---- 

 

 

IMG_5565.JPG

IMG_5563.JPG

  • Like 1

Share this post


Link to post
Share on other sites
 
32 minutes ago, Fishfiles said:

 ^Shade^ made me an offer to go thru  this red flake infested  300 engine , I am going to take him up on that offer  , I know it will be done first class ---- got to get it out the frame  and on a GreyHound bus up to Arkansas ,a multi-state rebuild 

 

Found a pic when the powder coating job  was first done -------  beauty is only skin deep on this one ---- cause it is ugly inside ---- 

 

 

IMG_5565.JPG

IMG_5563.JPG

lol fish ^^^, i'll take care of ya bro..will be done right !!! ( by my standards anyway )..lol. jeeps69 seems to be happy with the engine I did for him !..lol.

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
 

be sure to get me all gaskets, any oil seals you may need ?, i'll tear it apart, go through it, put it back together, and get it on its way back to ya !.

  • Like 2

Share this post


Link to post
Share on other sites
 
 
1 minute ago, Fishfiles said:

Which brand gasket kit do you prefer !!!

I normally use vesrah or namura..either one is good.

Share this post


Link to post
Share on other sites
 

Also I have a never been opened  in the box G+H re-bored jug with a Shindy piston and ring set , might as well start off fresh again , I would guess that red engine has only got a little more than a couple of hundred  hours on it , but  it got pretty hot a couple of times , temp light never came on , but that light is a too late thing  

Share this post


Link to post
Share on other sites
 
Just now, Fishfiles said:

Also I have a never been opened  in the box G+H re-bored jug with a Shindy piston and ring set , might as well start off fresh again , I would guess that red engine has only got a little more than a couple of hundred  hours on it , but  it got pretty hot a couple of times , temp light never came on , but that light is a too late thing  

sure, send it all, I'll take care of ya !

 

  • Like 1

Share this post


Link to post
Share on other sites
 

I can't test run it ?..but I know it will run !..lol.

Share this post


Link to post
Share on other sites
 

and of course..there is no charge for this !!, some day when I get down that way ?, you can make up for it !..lol.

  • Like 3

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...